summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryochananmarqos2019-08-22 09:19:34 -0600
committeryochananmarqos2019-08-22 09:19:34 -0600
commit99e6061aa0aa372cd4b3c2e71da83df8a8ed72ac (patch)
tree33656e3091d75358020c8a8c9c36920294629d52 /PKGBUILD
downloadaur-99e6061aa0aa372cd4b3c2e71da83df8a8ed72ac.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cef3fa85fdd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+pkgname=gammy-git
+pkgver=0.9.42.r18.1c7b3b6
+pkgrel=1
+pkgdesc="Automatic screen brightness tool."
+arch=('x86_64')
+url="https://getgammy.com"
+license=('GPL3')
+depends=('mesa' 'qt5-base')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/Fushko/gammy.git'
+ "${pkgname%-git}.desktop")
+sha256sums=('SKIP'
+ '32bdd9ae6e2eac460bbcc02c4f6cba6428d557e2c471fc67727d9c6a231f6764')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ qmake Gammy.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -d "$pkgdir/usr/bin"
+ ln -s /opt/Gammy/bin/Gammy "$pkgdir/usr/bin/gammy"
+ install -Dm644 "$srcdir/${pkgname%-git}.desktop" \
+ "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+}