summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaphaël Doursenaud2015-07-05 17:58:47 +0200
committerRaphaël Doursenaud2015-07-05 17:58:47 +0200
commit6e6c021e0665c6e23f18c1d5af3fcee1f5b6d2a4 (patch)
tree7ac73e0755a440c6d5d07ae241c11ce6d1ade971 /PKGBUILD
downloadaur-6e6c021e0665c6e23f18c1d5af3fcee1f5b6d2a4.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa4ad471f1aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Raphaël Doursenaud <rdoursenaud@gpcsolutions.fr>
+pkgname=gandi.cli
+pkgver=0.14
+pkgrel=1
+pkgdesc="Gandi command line interface"
+arch=('any')
+url="http://cli.gandi.net"
+license=('GPL3')
+groups=()
+depends=('python3' 'python-yaml' 'python-click' 'python-requests' 'python-ipy' 'openssl' 'openssh' 'git')
+optdepends=('docker: gandi docker support')
+makdepends=('python-setuptools')
+checkdepends=('python-nose' 'python-coverage' 'python-tox' 'python-mock')
+makedepends=('python-docutils')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://github.com/Gandi/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('62bef7ae281350ebeeb2d741de55ed5cec6d4dda1e29c3d6c98a73445db27b56')
+
+build() {
+ # Building the manpage
+ cd "$srcdir/$pkgname-$pkgver"
+ rst2man --no-generator gandicli.man.rst > gandi.1
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ # Installing the manpage
+ install -d $pkgdir/usr/share/man/man1/
+ install -m 644 *.1 $pkgdir/usr/share/man/man1/
+}
+
+# vim:set ts=2 sw=2 et: