summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTyler Langlois2019-05-09 23:33:00 -0600
committerTyler Langlois2019-05-09 23:33:00 -0600
commitb19bd5ad3d9aa3443a8874bff1968e1bb01624bf (patch)
treed3b7a90827a02df7c34d960b1ca1a2a77fe51427 /PKGBUILD
parentebd1a3cd23dbf89e294f3dd9cf2e7355e03295a1 (diff)
downloadaur-b19bd5ad3d9aa3443a8874bff1968e1bb01624bf.tar.gz
ganglia: fix sun library configure errors, bump release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bea3598943b..35040b777af4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ganglia
pkgver=3.7.2
-pkgrel=3
+pkgrel=4
pkgdesc="A scalable distributed monitoring system for high-performance computing systems such as clusters and Grids."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://${pkgname}.sourceforge.net/"
@@ -40,16 +40,19 @@ prepare() {
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr \
- --sbindir=/usr/bin \
- --libdir=/usr/lib \
- --sysconfdir=/etc/ganglia \
- --enable-gexec \
- --enable-status \
- --with-gmetad \
- --with-riemann \
- --with-python=/usr/bin/python2 \
- --with-systemdsystemunitdir=/usr/lib/systemd/system
+ # Required to work around Sun RPC (ONC/RPC) library errors
+ LDFLAGS=-ltirpc \
+ CFLAGS=-I/usr/include/tirpc \
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --sysconfdir=/etc/ganglia \
+ --enable-gexec \
+ --enable-status \
+ --with-gmetad \
+ --with-riemann \
+ --with-python=/usr/bin/python2 \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
make
}