summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAutumn2023-05-23 13:24:17 -0700
committerAutumn2023-05-23 13:24:17 -0700
commit3c4c1694cc434df9428fbb347ea3d16af15a8618 (patch)
tree6b5cf88da8f92a11e926e52f6dfab20343d0d61a /PKGBUILD
parent0a6b3f4f99ba8c6e2e653a519657dcd75b9b5608 (diff)
downloadaur-3c4c1694cc434df9428fbb347ea3d16af15a8618.tar.gz
fix build error caused by not including <cstdint>
not bumping pkgrel because people who already have the package installed have no need for this change.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c27651aa594b..92d268a78100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,8 +21,15 @@ conflicts=('gargoyle-mod')
replaces=('gargoyle-mod')
backup=('etc/garglk.ini')
#groups=(inform)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/garglk/garglk/archive/${pkgver}.tar.gz")
-sha512sums=('d8624f8a8492f64adfdb638811419ebef5b77457708a5d07a3891faf97966237839170914af4d416f42aca7e6d9d0643384ef60be30a2ba22ed52fee4938683a')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/garglk/garglk/archive/${pkgver}.tar.gz"
+ "0001-include-cstdint-in-garglk.h.patch")
+sha512sums=('d8624f8a8492f64adfdb638811419ebef5b77457708a5d07a3891faf97966237839170914af4d416f42aca7e6d9d0643384ef60be30a2ba22ed52fee4938683a'
+ '0db975cdb44cd155e0962a4a141eba7b5990175ccb65bbb71b7f504bc140e29079da5a7f23bdd429dd68c75b6b2fff320f0ea5cb689aaa5c79dae1642d94cf4f')
+
+prepare() {
+ cd "${srcdir}/garglk-${pkgver}"
+ patch -Np1 -i "${srcdir}/0001-include-cstdint-in-garglk.h.patch"
+}
build() {
cd "${srcdir}/garglk-${pkgver}"