summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-13 23:09:46 +0800
committerChocobo12017-08-13 23:19:43 +0800
commit45398df071e9e14b20a5b2f20225b4024f959f67 (patch)
tree5c47e3348983c51112884a3921d16a9c87652bf1 /PKGBUILD
downloadaur-45398df071e9e14b20a5b2f20225b4024f959f67.tar.gz
newpkg: gawk-git 4.1.4.r1635.g5557a45f-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7555301a03a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gawk-git
+pkgver=4.1.4.r1635.g5557a45f
+pkgrel=1
+pkgdesc="GNU version of awk"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/gawk/"
+license=('GPL3')
+depends=('glibc' 'mpfr')
+makedepends=('git')
+provides=('awk')
+conflicts=('gawk')
+source=("git+https://git.savannah.gnu.org/git/gawk.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "gawk"
+
+ git describe --long --tags | sed 's/^gawk-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "gawk"
+
+ ./bootstrap.sh
+ ./configure --prefix="/usr" --without-libsigsegv
+ make
+}
+
+check() {
+ cd "gawk"
+
+ make check
+}
+
+package() {
+ cd "gawk"
+
+ make DESTDIR="$pkgdir" install
+}