summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick McCarty2023-11-16 14:22:53 -0800
committerPatrick McCarty2023-11-16 14:22:53 -0800
commit7e37eeb15a4b4513a2a4363f72233e479ed4a134 (patch)
treeab0fa6d9757a0de25da2ffae64b8f294d84718b1 /PKGBUILD
parent907fea381436e48037ed4f8333c07251994f5ac0 (diff)
downloadaur-7e37eeb15a4b4513a2a4363f72233e479ed4a134.tar.gz
Run test suite in serial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cda647faafc1..eb0742e86e9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,8 +21,9 @@ build() {
check() {
cd "$pkgname-$pkgver"
- # sometimes the test suite fails -- race condition?
- make -k check || :
+ # Sometimes the test suite fails due to a race condition when running
+ # multiple tests in parallel. Force a single job for now.
+ make -j1 -k check
}
package() {