diff options
author | Alex Dewar | 2022-05-09 16:06:20 +0100 |
---|---|---|
committer | Alex Dewar | 2022-05-09 16:06:20 +0100 |
commit | 63a935302d33e6cf1fd2ba26dfb0df65e0296184 (patch) | |
tree | 8b350ae28144919b8eeaee731228af41aad0b741 /PKGBUILD | |
parent | 928c396882720f7a9aaeb77a87bfe0b1e1313e8b (diff) | |
download | aur-63a935302d33e6cf1fd2ba26dfb0df65e0296184.tar.gz |
v11.9.1 + various fixes
Fixes backported for build issues relating to TBB and protobuf.
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 29 |
1 files changed, 17 insertions, 12 deletions
@@ -8,35 +8,39 @@ pkgname=gazebo pkgver=11.9.1 -pkgrel=1 +pkgrel=2 pkgdesc="A multi-robot simulator for outdoor environments" arch=('i686' 'x86_64') url="http://gazebosim.org/" license=('Apache') # See: http://www.gazebosim.org/tutorials?tut=install_from_source&cat=install -depends=('boost' 'curl' 'freeglut' 'freeimage' 'intel-tbb' 'libccd' 'libltdl' 'graphviz' +depends=('boost' 'curl' 'freeglut' 'freeimage' 'tbb' 'libccd' 'libltdl' 'graphviz' 'libtar' 'libxml2' 'ogre-1.9' 'protobuf>=2.3.0' 'sdformat-9' 'ignition-math>=6' 'ignition-transport-8' 'ignition-cmake>=2' 'ignition-common-3' 'ignition-fuel_tools-4' 'ignition-msgs-5' 'tinyxml2' 'qwt') optdepends=('bullet: Bullet support' 'cegui: Design custom graphical interfaces' - 'ffmpeg: Playback movies on textured surfaces' + 'ffmpeg4.4: Playback movies on textured surfaces' 'gdal: Digital elevation terrains support' 'libdart: DART support' 'libspnav: space navigator joystick support' 'libusb: USB peripherals support' 'simbody: Simbody support' 'urdfdom: Load URDF files') -makedepends=('cmake' 'ninja' 'doxygen' 'ruby-ronn') +makedepends=('cmake' 'git' 'ninja' 'doxygen' 'ruby-ronn') install="${pkgname}.install" -source=("http://osrf-distributions.s3.amazonaws.com/$pkgname/releases/$pkgname-$pkgver.tar.bz2" - "fix-for-tbb-2021.patch") -sha256sums=('2959f4bed5fa8b5aa7f86bcd518e74a65402fe21b91a8d125807117827731be6' - '7998432d57df6fc729f4289902b374c350363520f7a06bc808b437c904e26f59') +source=("git+https://github.com/osrf/gazebo.git#tag=gazebo11_$pkgver" + "fix-for-tbb-2021.patch") +sha256sums=('SKIP' + '5a185f53ad1649945c1ffcf6c61c86631bd35917547eac3b14b33ca177a4e6bb') prepare() { - cd "${srcdir}/${pkgname}-${pkgver}" + cd "${srcdir}/${pkgname}" - # Gazebo's CMake package file forces projects using it to use C++11 by default which screws over anyone wanting to use C++14 or newer + # Fix for newer versions of protobuf + git cherry-pick 2f0f7af4868883d1a6fea30086b3fcd703d583fc + + # Gazebo's CMake package file forces projects using it to use C++11 by default + # which screws over anyone wanting to use C++14 or newer sed -i '/-std=c++11/d' cmake/gazebo-config.cmake.in # Workaround for this issue: https://github.com/osrf/gazebo/issues/2867 @@ -44,10 +48,11 @@ prepare() { } build() { - cd "${srcdir}/${pkgname}-${pkgver}" + cd "${srcdir}/${pkgname}" mkdir -p build && cd build + export PKG_CONFIG_PATH=/usr/lib/ffmpeg4.4/pkgconfig cmake .. -GNinja \ -DCMAKE_BUILD_TYPE="Release" \ -DCMAKE_INSTALL_PREFIX="/usr" \ @@ -56,6 +61,6 @@ build() { } package() { - cd "${srcdir}/${pkgname}-${pkgver}/build" + cd "${srcdir}/${pkgname}/build" DESTDIR="${pkgdir}" ninja install } |