summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Dewar2020-01-16 12:11:11 +0000
committerAlex Dewar2020-01-16 12:11:11 +0000
commita2d7e534fa1861a4e181226a6ebb429984b3d7ab (patch)
treeb44c6518471e16a2234258a3768146ab10a12ae1 /PKGBUILD
parent0e9e9c29778139351be6578c2d480528fc761eb8 (diff)
downloadaur-a2d7e534fa1861a4e181226a6ebb429984b3d7ab.tar.gz
We still need fix-al.patch...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae28315a7e47..42fa39a38655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,13 +31,17 @@ optdepends=('bullet: Bullet support'
makedepends=('cmake' 'doxygen' 'ignition-cmake')
install="${pkgname}.install"
source=("http://osrf-distributions.s3.amazonaws.com/$pkgname/releases/$pkgname-$pkgver.tar.bz2"
- "fix-moc.patch::https://bitbucket.org/osrf/gazebo/commits/9d71a6134982e2bf60ce96ca97c18c956c0cc7e0/raw")
+ "fix-moc.patch::https://bitbucket.org/osrf/gazebo/commits/9d71a6134982e2bf60ce96ca97c18c956c0cc7e0/raw"
+ "fix-openal.patch::https://bitbucket.org/shrit/gazebo/commits/556354dcebd180e0f1015b96890f9906e441b551/raw")
sha256sums=('8a1fcf8697704928c9cda610a9ce81f563f211bdfb2f1fdb458193ffb36c4287'
- 'f69a8dfb3224a93a50b0e10d80a0b42f8652eb667dcbacc741b5c8a638b1e768')
+ 'f69a8dfb3224a93a50b0e10d80a0b42f8652eb667dcbacc741b5c8a638b1e768'
+ '4b386e845e94008102609a4fb666d698bee0480d2ce88b250dc1d849cfc93b72')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch --strip=1 --input=../fix-moc.patch
+ for patch in ../*.patch; do
+ patch --strip=1 --input=$patch
+ done
}
build() {