summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpzl2015-08-08 11:38:43 -0400
committerpzl2015-08-08 11:41:05 -0400
commit63604550d8d85474626f5f416058ec0f268e71e9 (patch)
treefda4c313a69778d13fc190cd2b1a6f87f91d66c5 /PKGBUILD
downloadaur-63604550d8d85474626f5f416058ec0f268e71e9.tar.gz
moving old PKGBUILD to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83c585e3ad17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Olivier Duclos <olivier.duclos@gmail.com>
+# Maintainer: Dan Panzarella <alsoelp@gmail.com>
+
+pkgname=gbdfed
+pkgver=1.6
+pkgrel=3
+pkgdesc="A GTK2 bitmap font editor"
+arch=(i686 x86_64)
+url="http://www.math.nmsu.edu/~mleisher/Software/gbdfed/"
+license=('MIT')
+depends=(gtk2)
+source=(http://www.math.nmsu.edu/~mleisher/Software/gbdfed/$pkgname-$pkgver.tbz2 \
+ http://www.math.nmsu.edu/~mleisher/Software/gbdfed/gbdfed48x48.png \
+ gbdfed.desktop \
+ num_signals.patch)
+md5sums=('2a2e1cbfe8566db6d302f0b9ab79b8dd'
+ '3681abf22f23a62c48acfca417655dd0'
+ '9e4dd5cb12245e7ea51f53085a714360'
+ '0034b837f9217ebdf5a271d2e242d635')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ sed -i 's/-D.*_DEPRECATED\s*\\*//' Makefile.in
+ patch -p1 < ../num_signals.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+ install -d $pkgdir/usr/share/{applications,pixmaps}
+ install -m644 ../gbdfed.desktop $pkgdir/usr/share/applications/
+ install -m644 ../gbdfed48x48.png $pkgdir/usr/share/pixmaps/gbdfed.png
+}