summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Riedel2020-06-15 14:42:05 +0200
committerSebastian Riedel2020-06-15 14:42:05 +0200
commitbb1a920c62df7c87177371d3b1eb6df1a564ab9f (patch)
treedd62d64743dd01b2ddda0e3f3e969bc9ff81282d /PKGBUILD
downloadaur-bb1a920c62df7c87177371d3b1eb6df1a564ab9f.tar.gz
Add version 3.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cda2c90b8220
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: basxto <archlinux basxto de>
+# based on gbdk package
+
+pkgname=gbdk-2020
+pkgver=3.2
+pkgrel=1
+pkgdesc="An updated version of Game Boy Development Kit"
+url="https://github.com/Zal0/gbdk-2020"
+license=('MIT')
+arch=('x86_64' 'i686')
+makedepends=('sdcc')
+depends=('sdcc')
+conflicts=('gbdk' 'lcc')
+source=("git+https://github.com/basxto/gbdk-2020#commit=01cdbb621afa61de77e394de76161bd8aa65848d")
+#should be merged in the next version
+#source=("https://github.com/Zal0/gbdk-2020/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ sed "s|%prefix%bin/|/usr/bin/|g" -i ${pkgname}/gbdk-support/lcc/gb.c
+ make -C ${pkgname} gbdk-build SDCCDIR=/usr/
+ make -C ${pkgname} gbdk-install-nosdcc SDCCDIR=/usr/
+ mkdir -p ${pkgdir}/usr
+ mkdir -p ${pkgdir}/opt
+
+ mv ${pkgname}/build/gbdk ${pkgdir}/opt/gbdk
+ mv ${pkgdir}/opt/gbdk/bin ${pkgdir}/usr/
+ find ${pkgdir}/opt/gbdk/ -type f -name '*.bat' -delete
+}