summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212023-11-17 16:33:56 +0100
committera8212023-11-17 16:33:56 +0100
commitb020277707b65e33ae7439eada6b05ad931c1197 (patch)
tree1dce7079b7f96745d389efc5d70d4f3c6f27f506 /PKGBUILD
parent0288bf0c82e64f5ae8e3214021d220d792a6e7fe (diff)
downloadaur-gc-git.tar.gz
Add git to makedeps. Update license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55f5d849ea44..f23f86025058 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
# Contributor: dorphell <dorphell@gmx.net>
pkgname=gc-git
-pkgver=8.2.0.r513.g515d30eb
+pkgver=8.2.0.r1165.gf2630a42
pkgrel=1
pkgdesc="A garbage collector for C and C++"
arch=('x86_64')
url="https://www.hboehm.info/gc/"
-license=('GPL')
+license=('MIT')
depends=('gcc-libs')
+makedepends=('git')
source=($pkgname::git+https://github.com/ivmai/bdwgc.git)
sha512sums=('SKIP')
conflicts=('gc')
@@ -42,4 +43,5 @@ package() {
make DESTDIR="${pkgdir}" install
sed 's|GC_MALLOC 1L|gc 3|g' gc.man |
install -Dm644 /dev/stdin "${pkgdir}/usr/share/man/man3/gc.3"
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}