summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBienChen2021-04-23 14:55:42 +0800
committerBienChen2021-04-23 14:55:42 +0800
commit54625802d8797f89e2eac21df1c37f0a7b91c077 (patch)
tree63af5bc23d75aebef325b4b317d0d093378efa25 /PKGBUILD
parentea5de2cd646b74be0a3dd1656bbf70f5fc91ced6 (diff)
downloadaur-54625802d8797f89e2eac21df1c37f0a7b91c077.tar.gz
Add \!strip and symlink for binary files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88c9b60af31f..28ed41805848 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
pkgname=gcc-nuclei-bin
_pkgname=Nuclei-Toolchain
pkgver=2020.08
-pkgrel=1
+pkgrel=2
pkgdesc='GNU Compiler Collection for RISC-V processor from Nuclei System Technology (official build).'
arch=('x86_64')
url='https://nucleisys.com/download.php'
license=('GPL LGPL FDL custom')
+options=('!strip')
install="${pkgname}.install"
source=("https://nucleisys.com/upload/files/toochain/gcc/nuclei_riscv_newlibc_prebuilt_linux64_${pkgver}.tar.bz2")
sha256sums=('398c25b9385b8122d2e864bf71e47b1d871f6c326c21d0ae6d3afd2858f36041')
@@ -21,4 +22,10 @@ prepare() {
package() {
mv "${srcdir}/opt" "${pkgdir}/"
+ install -dm755 "${pkgdir}/usr/bin"
+ cd "${pkgdir}/opt/${_pkgname}/gcc/bin"
+ for file in *
+ do
+ ln -s "/opt/${_pkgname}/gcc/bin/$file" "${pkgdir}/usr/bin/"
+ done
}