summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBienChen2021-04-01 16:49:07 +0800
committerBienChen2021-04-01 16:49:07 +0800
commitea5de2cd646b74be0a3dd1656bbf70f5fc91ced6 (patch)
tree7871479550cdec1618f8d38a9f3d9914dee063dc /PKGBUILD
downloadaur-ea5de2cd646b74be0a3dd1656bbf70f5fc91ced6.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88c9b60af31f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: BienChen <binchan at gmx dot com>
+
+pkgname=gcc-nuclei-bin
+_pkgname=Nuclei-Toolchain
+pkgver=2020.08
+pkgrel=1
+pkgdesc='GNU Compiler Collection for RISC-V processor from Nuclei System Technology (official build).'
+arch=('x86_64')
+url='https://nucleisys.com/download.php'
+license=('GPL LGPL FDL custom')
+install="${pkgname}.install"
+source=("https://nucleisys.com/upload/files/toochain/gcc/nuclei_riscv_newlibc_prebuilt_linux64_${pkgver}.tar.bz2")
+sha256sums=('398c25b9385b8122d2e864bf71e47b1d871f6c326c21d0ae6d3afd2858f36041')
+noextract=("nuclei_riscv_newlibc_prebuilt_linux64_${pkgver}.tar.bz2")
+
+prepare() {
+ mkdir -p "${srcdir}/opt/${_pkgname}"
+ bsdtar -xf "nuclei_riscv_newlibc_prebuilt_linux64_${pkgver}.tar.bz2" \
+ -C "${srcdir}/opt/${_pkgname}"
+}
+
+package() {
+ mv "${srcdir}/opt" "${pkgdir}/"
+}