summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlibele2021-07-06 16:46:38 -0500
committerlibele2021-07-06 16:46:38 -0500
commit4eccec88994925a09f7b0573237a529c00d395ab (patch)
treed014b6bf86db23e8b128b74f594d8f5ad1a24891 /PKGBUILD
downloadaur-4eccec88994925a09f7b0573237a529c00d395ab.tar.gz
not sure if this will work forever
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6623d8758ccc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# maintainer: libele <libele@disroot.org>
+
+pkgname=gcc34-bin
+pkgver=3.4.6.4.1
+_rpmver=3.4.6-4.1
+pkgrel=1
+pkgdesc="Compatibility GNU Compiler Collection."
+arch=('x86_64')
+url="https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/repoview/compat-gcc-34.html"
+license=('GPL2' 'LGPL')
+options=(!strip)
+provides=('gcc34')
+depends=('libf2c')
+makedepends=('rpmextract')
+source=("https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/compat-gcc-34-${_rpmver}.x86_64.rpm")
+md5sums=('39584eda9be14f39194f8961482cf25c')
+noextract=("https://linuxsoft.cern.ch/cern/slc5X/x86_64/yum/updates/compat-gcc-34-${_rpmver}.x86_64.rpm")
+
+prepare() {
+ cd "${srcdir}"
+ rpmextract.sh compat-gcc-34-3.4.6-4.1.x86_64.rpm
+}
+
+package() {
+ cd "${srcdir}"
+ mv usr "${pkgdir}"/usr
+ cd "${pkgdir}"/usr/share/doc
+ mv compat-gcc-34-3.4.6 gcc-34
+}