summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2019-07-18 16:19:31 -0400
committerChris Severance2019-07-18 16:19:31 -0400
commita480549964d73909b2800bbb43526327bbeacca5 (patch)
tree30741a2c7877de86edbca1d94ae853d4cf13ca3a /PKGBUILD
parent8d0c46101924a00a043ec8bcb3acd749f594aeab (diff)
downloadaur-a480549964d73909b2800bbb43526327bbeacca5.tar.gz
autu: Update to 6.4.1_20181024-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4684380a3b2..d7250f1ea2b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -200,10 +200,19 @@ build() {
if [ "${_opt_CPP_ONLY}" -eq 0 ]; then
_languages+=',fortran,go,lto,objc,obj-c++'
fi
+
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
- CFLAGS="${CFLAGS/-pipe/}" \
- CXXFLAGS="${CXXFLAGS/-pipe/}" \
+ CFLAGS="${CFLAGS/-pipe/}"
+ CXXFLAGS="${CXXFLAGS/-pipe/}"
+
+ # Flags from new compilers that old compilers don't recognize
+ CFLAGS="${CFLAGS/-fno-plt/}"
+ CXXFLAGS="${CXXFLAGS/-fno-plt/}"
+
+ CFLAGS="${CFLAGS/-Wformat-overflow=[0-9]/}"
+ CXXFLAGS="${CXXFLAGS/-Wformat-overflow=[0-9]/}"
+
../configure "${_cfgopts[@]}" \
--build="${CHOST}" \
--disable-libstdcxx-pch \