summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrobot Viktor2019-09-03 00:29:30 +0300
committerDrobot Viktor2019-09-03 00:29:30 +0300
commitd536b2e43937186530d98212a775a19faef9171c (patch)
tree59d23d8f70fb3a76bef396477164f65ceb4f844a /PKGBUILD
parentae6d40f27fd4db58bbda3002a537109bfd006485 (diff)
downloadaur-d536b2e43937186530d98212a775a19faef9171c.tar.gz
Fixed issue with libtool
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0bafa48dbd60..9651d40ae77c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ pkgver=7.4.1+20181207
_pkgver=7
_majorver=${pkgver:0:1}
_islver=0.18
-pkgrel=4
+pkgrel=5
pkgdesc='The GNU Compiler Collection (7.x.x)'
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -72,6 +72,8 @@ prepare() {
}
build() {
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
# using -pipe causes spurious test-suite failures
@@ -122,6 +124,8 @@ package_gcc7-libs() {
depends=('glibc>=2.27')
options+=(!strip)
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
make -C $CHOST/libgcc DESTDIR="$pkgdir" install-shared
rm -f "$pkgdir/$_libdir/libgcc_eh.a"
@@ -152,6 +156,8 @@ package_gcc7() {
depends=("gcc7-libs=$pkgver-$pkgrel" 'binutils>=2.28' libmpc)
options+=(staticlibs)
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
make -C gcc DESTDIR="$pkgdir" install-driver install-cpp install-gcc-ar \
@@ -208,6 +214,8 @@ package_gcc7-fortran() {
depends=("gcc7=$pkgver-$pkgrel")
options=('!emptydirs')
+ export LD_PRELOAD=/usr/lib/libstdc++.so
+
cd gcc-build
make -C $CHOST/libgfortran DESTDIR=$pkgdir install-cafexeclibLTLIBRARIES \
install-{toolexeclibDATA,nodist_fincludeHEADERS}