summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralrii2018-01-16 01:50:45 -0500
committeralrii2018-01-16 01:50:45 -0500
commit954645aaceea4412bc4545ceff48da39838250d4 (patch)
treed081b4c0f54f9c0cf629b69f4b1ef07b4d103f6c /PKGBUILD
parent5ab4187a4651b643f731edfaa60471c10175a99b (diff)
downloadaur-954645aaceea4412bc4545ceff48da39838250d4.tar.gz
Change dependency, Change source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96cc8daf471c..1c085267f1f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
+# Maintainer: Alrii14344 <alrii14344@gmail.com>
# Maintainer: Kohei Suzuki <eagletmt@gmail.com>
+
pkgname=gce-compute-image-packages
-pkgver=20170523
-pkgrel=2
+pkgver=0.0.0
+pkgrel=1
pkgdesc='Linux Guest Environment for Google Compute Engine'
-arch=('any')
+arch=('x86_64')
url='https://github.com/GoogleCloudPlatform/compute-image-packages'
license=('Apache')
-depends=('python-boto' 'python-setuptools')
-source=("https://github.com/GoogleCloudPlatform/compute-image-packages/archive/${pkgver}.tar.gz")
+depends=('python-boto' 'python-setuptools' 'git')
+source=("$pkgname"::'git://github.com/GoogleCloudPlatform/compute-image-packages.git')
+# Because the sources are not static, skip Git checksum:
+sha512sums=('SKIP')
package() {
- cd "compute-image-packages-$pkgver"
+ cd "gce-compute-image-packages"
python setup.py install --root="$pkgdir"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -20,6 +24,4 @@ package() {
do
install -m644 "$unit" "$pkgdir/usr/lib/systemd/system/"
done
-}
-
-sha512sums=('f72f46b962ef58b5d89a7eff0aff0abc3bb41fe33fd5fff0d8c2b2c08110f73316ed7fb0b6c9ea9c0c9a24760877a2b3da8facca81c15a47829b7a1af6bb2fd0')
+} \ No newline at end of file