summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2020-09-08 23:11:49 +0100
committerJoão Figueiredo2020-09-08 23:11:49 +0100
commit66ca4e3a427c8a2eae4d0b3f1554e88d53a6ff06 (patch)
treea2d63ba651614bb28ca22c58c19f25b03c678707 /PKGBUILD
parentd2932e89a20c2cc95c5cfd9160b81c56aa8db8be (diff)
downloadaur-66ca4e3a427c8a2eae4d0b3f1554e88d53a6ff06.tar.gz
Re-added commit, added some ""
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f085b2786e1e..bfe450aff5bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gconf
pkgver=3.2.6+11+g07808097
-pkgrel=8
+pkgrel=9
pkgdesc="An obsolete configuration database system"
url="https://projects-old.gnome.org/gconf/"
arch=(x86_64)
@@ -11,7 +11,8 @@ license=(LGPL)
depends=(libxml2 polkit libldap dbus-glib python)
makedepends=(intltool gtk-doc gobject-introspection git gnome-common)
install=gconf.install
-source=("git+https://gitlab.gnome.org/Archive/gconf.git"
+_commit=0780809731c8ab1c364202b1900d3df106b28626 # The latest and last commit, dug out from deep within the waves of time...
+source=("git+https://gitlab.gnome.org/Archive/gconf.git#commit=$_commit"
01_xml-gettext-domain.patch gconf-reload.patch
gconf-merge-schema gconfpkg gconf-{install,remove}.hook)
sha256sums=('SKIP'
@@ -22,11 +23,6 @@ sha256sums=('SKIP'
'2732b2a6b187c5620105a036bde12edee99669605f70cbde56fe5f39619c3dc0'
'436a65ff290095bc3d35d7d6297cf4d647f61e9f9922cea7ef9f1e251b447ff7')
-pkgver() {
- cd $pkgname
- git describe --tags | sed 's/-/+/g'
-}
-
prepare() {
cd $pkgname
@@ -70,10 +66,10 @@ package() {
install -d "$pkgdir/etc/gconf/gconf.xml.system"
install -Dt "$pkgdir/usr/bin" gconf-merge-schema gconfpkg
- install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ./*.hook
# fix dbus policy location - --with-dbusdir doens't work
- install -dm755 ${pkgdir}/usr/share/dbus-1/system.d
- mv ${pkgdir}/etc/dbus-1/system.d/* ${pkgdir}/usr/share/dbus-1/system.d
- rm -rf ${pkgdir}/etc/dbus-1
+ install -dm755 "$pkgdir/usr/share/dbus-1/system.d"
+ mv "$pkgdir"/etc/dbus-1/system.d/* "$pkgdir/usr/share/dbus-1/system.d"
+ rm -rf "$pkgdir/etc/dbus-1"
}