summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2017-06-03 02:45:10 -0600
committerBrian Bidulock2017-06-03 02:45:10 -0600
commitadf0492510ea582506eaad8837fa07ecb25e8d4a (patch)
tree0fda924f4ceee348cf0b899d55416d2ee213db47 /PKGBUILD
parent9844b3d3d6d07d6447fb7b190e868b3b52a52e48 (diff)
downloadaur-gconf-gtk2.tar.gz
version 3.2.6-5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3156ee9c31db..7ff1c52680fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 266210 2016-04-27 12:18:24Z allan $
+# $Id: PKGBUILD 273521 2016-08-08 22:26:45Z jgc $
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributor: Jan de Groot <jan@archlinux.org>
pkgname=gconf-gtk2
pkgver=3.2.6
-pkgrel=4
+pkgrel=5
pkgdesc="A configuration database system compiled for GTK2"
arch=(i686 x86_64)
license=('LGPL')
@@ -19,14 +19,18 @@ source=(https://download.gnome.org/sources/GConf/3.2/GConf-$pkgver.tar.xz
gconfpkg
gconf-reload.patch
gconf-{install,remove}.hook
- 01_xml-gettext-domain.patch)
+ 01_xml-gettext-domain.patch
+ dbus-dontspew.patch
+ gsettings-data-convert-fix-invalid-schema-path.patch)
sha256sums=('1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c'
'ee6b6e6f4975dad13a8c45f1c1f0547a99373bdecdcd6604bfc12965c328a028'
'bf1928718caa5df2b9e54a13cfd0f15a8fe0e09e86b84385ce023616a114e898'
'567b78d8b4b4bbcb77c5f134d57bc503c34867fcc6341c0b01716bcaa4a21694'
'2732b2a6b187c5620105a036bde12edee99669605f70cbde56fe5f39619c3dc0'
'436a65ff290095bc3d35d7d6297cf4d647f61e9f9922cea7ef9f1e251b447ff7'
- 'c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8')
+ 'c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8'
+ 'b490394b0f541ca92134478fa2235536bdb1ccd3b3200d5040dd458cec33bfe8'
+ '0f2057fbd20837091cbcc1e291bb64c9c6066534891a4ee010bbf5b304bd831d')
prepare() {
cd "GConf-$pkgver"
@@ -36,6 +40,10 @@ prepare() {
# http://bugzilla.gnome.org/show_bug.cgi?id=568845
patch -Np1 -i "$srcdir/01_xml-gettext-domain.patch"
+ # Upstream fixes
+ patch -Np1 -i ../dbus-dontspew.patch
+ patch -Np1 -i ../gsettings-data-convert-fix-invalid-schema-path.patch
+
# Python2 fix
sed -i '1s|#!/usr/bin/env python$|&2|' gsettings/gsettings-schema-convert
}
@@ -49,6 +57,8 @@ build() {
--with-gtk=2.0 \
--disable-orbit
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
make pkglibdir=/usr/lib/GConf
}