summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-02-08 17:48:13 +0100
committerEmiel Wiedijk2018-02-08 17:48:13 +0100
commit203aa2069bcd81dbb37f6263d549c62fb27e187f (patch)
tree1aedae7910ed696a79051cb5974edf7f4bb6d9ce /PKGBUILD
parent914072f91c2b1414ae8d594a14cb2ec5815e3999 (diff)
downloadaur-203aa2069bcd81dbb37f6263d549c62fb27e187f.tar.gz
updpkg - gcsfuse 0.23.0
* Update to 0.23.0 * Build from GitHub tarball * Add .gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 66189ae99b9c..2432ef247f20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
-# Maintainer: zfo <zfoofz1@gmail.com>
+# Maintainer: aimileus <me at aimileus dot nl>
+# Contributor: zfo <zfoofz1@gmail.com>
pkgname=gcsfuse
-_pkgname=gcsfuse
-pkgver=0.16
+pkgver=0.23.0
pkgrel=1
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('APACHE')
-makedepends=('git' 'go')
-source=()
-sha256sums=()
+depends=('glibc')
+makedepends=('git' 'go-pie')
+optdepends=('google-cloud-sdk: authentication helper')
+source=("$pkgname-$pkgver::https://github.com/GoogleCloudPlatform/gcsfuse/archive/v$pkgver.tar.gz")
+sha256sums=('beb90ef68d5ab673bf09357c90d1ace94695bebb6f823ba715a92b30e61e7c39')
+_gourl=github.com/googlecloudplatform/gcsfuse
+
+prepare() {
+ export GOPATH="$srcdir/go"
+ mkdir -p "$GOPATH/src/$(dirname $_gourl)"
+ ln -sf "$srcdir/$pkgname-$pkgver" "$GOPATH/src/$_gourl"
+}
build() {
- GOPATH="$srcdir" go get -v -u github.com/googlecloudplatform/gcsfuse
+ export GOPATH="$srcdir/go"
+ go build "$_gourl"
}
package() {
- cd "$srcdir"
- install -Dm0755 bin/gcsfuse "${pkgdir}/usr/bin/gcsfuse"
+ install -Dm755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
}
# vim:set ts=2 sw=2 et: