summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorstocki2020-01-27 21:07:30 +0100
committerstocki2020-01-27 21:07:30 +0100
commiteb65805d7c28253516fd2b6ef7c3519dd3f1ba94 (patch)
treed8ec90047429e76db0121006251303cbf7c84304 /PKGBUILD
parent7fef64d9b12ea485c51a4b33068da44968a1c0d6 (diff)
downloadaur-eb65805d7c28253516fd2b6ef7c3519dd3f1ba94.tar.gz
Build mount.gcsfuse
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d5ebd072788..d77d4a5dabaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: zfo <zfoofz1@gmail.com>
pkgname=gcsfuse
pkgver=0.29.0
-pkgrel=2
+pkgrel=3
pkgdesc="A user-space file system for interacting with Google Cloud Storage"
url="https://github.com/GoogleCloudPlatform/gcsfuse"
arch=('x86_64')
@@ -24,9 +24,11 @@ prepare() {
build() {
export GOPATH="$srcdir/go"
go build "$_gourl"
+ CGO_ENABLED=1 go build -buildmode=pie -o "mount.gcsfuse" "$_gourl/tools/mount_gcsfuse"
}
package() {
install -Dm755 gcsfuse "${pkgdir}/usr/bin/gcsfuse"
- ln -s ${pkgdir}/usr/bin/gcsfuse ${pkgdir}/usr/bin/mount.gcsfuse
+ install -Dm755 mount.gcsfuse "${pkgdir}/usr/bin/mount.gcsfuse"
+ cd "${pkgdir}/usr/bin" && ln -s mount.gcsfuse mount.fuse.gcsfuse
}