summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMansour Behabadi2015-06-12 01:26:59 +1000
committerMansour Behabadi2015-06-12 01:26:59 +1000
commit3031d5bf221a3ef4e85a0d519c9c325e8b39daf0 (patch)
tree4c0f253c4455c9112b690906f8c21914341050b0 /PKGBUILD
downloadaur-gcsms-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56d0eb09a2b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mansour Behabadi <mansour@oxplot.com>
+
+pkgname=gcsms-git
+_gitname=gcsms
+pkgver=33.08e1bb3
+pkgrel=1
+pkgdesc='Send SMS for free through shell using Google Calendar API'
+arch=('any')
+url='https://github.com/oxplot/gcsms'
+license=('GPLv3')
+depends=('python')
+makedepends=('git')
+conflicts=('gcsms')
+provides=('gcsms')
+source=('git+https://github.com/oxplot/gcsms.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $_gitname
+ python setup.py build
+}
+
+package() {
+ cd $_gitname
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install license and docs
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -D -m644 sample.config "${pkgdir}/usr/share/doc/${pkgname}/sample.config"
+}