summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoshua Hardy2017-03-12 14:52:31 +1100
committerJoshua Hardy2017-03-12 14:52:31 +1100
commitba8e2b04395cbda260758979a2bd382008a1b3b9 (patch)
tree8959aa7709051559e81ee6209a6fc71f673a2886 /PKGBUILD
downloadaur-ba8e2b04395cbda260758979a2bd382008a1b3b9.tar.gz
first upload - cuda 8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ec558869cea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Joshua Hardy joshinsilico@gmail.com
+pkgname=gctf
+pkgver=1.06
+pkgrel=1
+pkgdesc="GPU accelerated program for Real-Time CTF determination, refinement, evaluation and correction."
+arch=(x86_64)
+url="http://www.mrc-lmb.cam.ac.uk/kzhang"
+license=('CCPL:cc-by-nc-nd-3.0')
+depends=('cuda')
+makedepends=()
+optdepends=()
+source=("http://www.mrc-lmb.cam.ac.uk/kzhang/Gctf/Gctf_v${pkgver}/bin/Gctf-v${pkgver}_sm_20_cu8.0_x86_64" "http://www.mrc-lmb.cam.ac.uk/kzhang/Gctf/Gctf_v${pkgver}/bin/Gctf-v${pkgver}_sm_30_cu8.0_x86_64")
+md5sums=('b7c66feab45e4924a48af7f7ed24a475' '4f343154991ad790d99043ae40b20fba')
+build() {
+ cd "${srcdir}"/
+ execstack -c Gctf*
+ echo "Gctf was designed by Kai Zhang@MRC Laboratory of Molecular Biology"
+}
+package() {
+ install -d "${pkgdir}"/usr "${pkgdir}"/usr/bin
+ install -D -m755 "${srcdir}"/* "${pkgdir}"/usr/bin/.
+}