summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFoppe Hemminga2015-07-07 13:18:54 +0200
committerFoppe Hemminga2015-07-07 13:18:54 +0200
commit85746bb47743206c8575b9b613f138cb7ba79038 (patch)
treeb5527a74694eb9f3b052fef6869ba99634070a59 /PKGBUILD
downloadaur-gcue2tracks.tar.gz
Initial commit copy of AUR3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81fde7dc6996
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Artem Sereda <overmind88@gmail.com>
+# Maintainer: Ferik <djferik at gmail dot com>
+
+pkgname=gcue2tracks
+pkgver=0.5.2
+pkgrel=3
+pkgdesc="Tool for spliting compressed audio CD image to tracks with filling tags from cue sheet info."
+arch=('i686' 'x86_64')
+url="http://trac-hg.assembla.com/gCue2tracks/wiki"
+license=('GPL')
+depends=('pygtk' 'cuetools' 'shntool' 'ffmpeg' 'unzip')
+optdepends=('id3v2: For MP3 tagging support')
+makedepends=('gettext')
+source=("${pkgname}-${pkgver}.tar.gz::https://www.assembla.com/spaces/gCue2tracks/documents/bgg6jqEgGr4PptacwqEsg8/download/bgg6jqEgGr4PptacwqEsg8")
+
+sha256sums=('3a46c3e0c26d143bb9d469ea074a257140aa285e777e83d745e5bab5000cad81')
+
+package() {
+
+cd "${srcdir}/gCue2tracks"
+
+sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+$(find . -name '*.py')
+sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" gcue2tracks
+
+python2 setup.py install --root=${pkgdir}
+
+chmod +x "${pkgdir}/usr/bin/gcue2tracks"
+
+} \ No newline at end of file