summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorggranga2017-02-10 10:49:34 +0100
committerggranga2017-02-10 10:49:34 +0100
commit357cc0c1bf27b8254f21a57dd82c5367b033183d (patch)
tree3bbceed45a79c2e1ca29927be14a4d4ae82bed6d /PKGBUILD
parent0b1999a5946145cb00c77e7432ea9dcc3a6edc90 (diff)
downloadaur-357cc0c1bf27b8254f21a57dd82c5367b033183d.tar.gz
Added a patch on jpeg2000_vsil_io.cpp to change uchar in unsigned char
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3cfa029b0fd..9341cc196208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=gdal-hdf4
_pkgname=gdal
pkgver=2.1.1
-pkgrel=4
+pkgrel=4.1
pkgdesc="A translator library for raster geospatial data formats, with support to HDF4 format (required to use MODIStsp tool: http://github.com/lbusett/MODIStsp)"
arch=('i686' 'x86_64')
url="http://www.gdal.org/"
@@ -45,12 +45,15 @@ build() {
export LDFLAGS="$LDFLAGS -Wl,--as-needed"
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 --with-geotiff \
- --with-mysql --with-python=/usr/bin/python2 --with-curl --with-hdf4 --with-hdf5 --with-perl --with-geos \
+ --with-mysql --with-python=/usr/bin/python2 --with-curl --with-hdf5 --with-hdf4 --with-perl --with-geos \
--with-png --with-poppler --with-spatialite --with-openjpeg
# workaround for bug #13646
sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
sed -i 's/EXE_DEP_LIBS/KILL_EXE_DEP_LIBS/' apps/GNUmakefile
+
+# bug: http://osgeo-org.1560.x6.nabble.com/gdal-dev-jpeg2000-jasper-error-compiling-gdal-2-1-from-git-release-branch-td5299100.html
+ sed -i -e 's@uchar@unsigned char@' frmts/jpeg2000/jpeg2000_vsil_io.cpp
make
make man