summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlireza |S.N|2023-11-05 09:04:44 +0330
committerAlireza |S.N|2023-11-05 09:04:44 +0330
commit003e3883711ab4418df6a1a330f4277aa8e62611 (patch)
treec0aa75cf114d99654a3adf28c7e3bf554bc3bbd4 /PKGBUILD
parent4776905d970f8c53a890f47a3af5270fbeba8251 (diff)
downloadaur-003e3883711ab4418df6a1a330f4277aa8e62611.tar.gz
Use the latest podofo library, no need for 0.9 anymore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 712e5ae987e9..4cba1ac0f08c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ makedepends=(cmake opencl-headers python-setuptools python-numpy
proj arrow blosc cfitsio curl crypto++ libdeflate expat libfreexl
libgeotiff geos giflib libheif hdf5 libjpeg-turbo json-c libjxl xz
libxml2 lz4 mariadb-libs netcdf unixodbc ocl-icd openexr openjpeg2
- openssl pcre2 libpng podofo-0.9 poppler postgresql-libs qhull
+ openssl pcre2 libpng podofo poppler postgresql-libs qhull
libspatialite sqlite swig libtiff libwebp xerces-c zlib zstd libkml-git)
# armadillo brunsli lerc libkml rasterlite2 sfcgal tiledb
# ogdi
@@ -25,10 +25,9 @@ changelog=gdal.changelog
source=(https://download.osgeo.org/gdal/${pkgver}/gdal-${pkgver}.tar.xz)
b2sums=('743ce2d8027fb228630a2951af2de8ac7fb5fa0b32124d58fb545ac61fdf5240f17ae85cfdcab51ea5e1b4e2311b55af4c7bbdfe82c6ed5ea180a5c8b254ccfd')
-prepare() {
- # Fix build with podofo-0.9
- sed -e 's|podofo.h|podofo/podofo.h|' -i gdal-$pkgver/frmts/pdf/pdfsdk_headers.h
-}
+# prepare() {
+#
+# }
build() {
cmake -B build -S gdal-$pkgver \
@@ -79,8 +78,6 @@ build() {
-DGDAL_USE_ZSTD=ON \
-DGDAL_USE_LIBKML=ON \
-DGDAL_USE_FileGDB=ON \
- -DPODOFO_INCLUDE_DIR=/usr/include/podofo-0.9 \
- -DPODOFO_LIBRARY=/usr/lib/podofo-0.9/libpodofo.so \
-DFileGDB_INCLUDE_DIR=/usr/include/filegdb-api/ \
-DFileGDB_LIBRARY=/usr/lib/libFileGDBAPI.so && \
make -C build -j $(nproc)
@@ -101,7 +98,7 @@ package_gdal-libkml-filegdb () {
'netcdf: netCDF support'
'openexr: EXR support'
'openjpeg2: JP2 support'
- 'podofo-0.9: PDF support'
+ 'podofo: PDF support'
'poppler: PDF support'
'postgresql-libs: PostgreSQL support'
'libwebp: WebP support')