summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikhail Burakov2018-03-21 13:02:51 +0100
committerMikhail Burakov2018-03-21 13:02:51 +0100
commit0035e8474dfb76de063727a6e84bd6c1cd3e4e09 (patch)
treee0c234b3fda2a1d2224c6b8360cb72ea680edf4d /PKGBUILD
downloadaur-0035e8474dfb76de063727a6e84bd6c1cd3e4e09.tar.gz
Initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f305d5748cac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Mikhail Burakov <mikhail.burakov@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gdb-mini
+pkgver=8.1
+pkgrel=1
+pkgdesc='The GNU Debugger without useless dependencies'
+arch=(x86_64)
+url='http://www.gnu.org/software/gdb/'
+license=(GPL3)
+makedepends=(texinfo)
+source=(https://ftp.gnu.org/gnu/gdb/gdb-${pkgver}.tar.xz)
+sha1sums=('641861f7d3f22b6a23bc3e801f0ff29a78375490')
+provides=(gdb)
+conflicts=(gdb)
+
+prepare() {
+ cd gdb-$pkgver
+
+ # credits go to maintainers of original gdb PKGBUILD
+ # hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+build() {
+ cd gdb-$pkgver
+ ./configure --prefix=/usr --with-system-zlib --disable-nls --disable-tui \
+ --disable-gdbserver --with-system-readline --without-expat \
+ --without-mpfr --without-python --without-guile --without-intel-pt \
+ --without-lzma --without-babeltrace
+ make
+}
+
+package() {
+ cd gdb-$pkgver
+ make DESTDIR=$pkgdir install
+
+ rm $pkgdir/usr/bin/gcore
+ rm -r $pkgdir/usr/{include,lib,share}
+}