summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames P. Harvey2018-10-13 02:51:14 -0400
committerJames P. Harvey2018-10-13 02:56:04 -0400
commit5aa298060ba5b23eba931e686c88f0ef1d7f38e0 (patch)
tree8011c1bcb3de2069561c28989fab1effa87745f1 /PKGBUILD
parent2a93ac808eb3881d893ba95fce13013e0a316d9d (diff)
downloadaur-5aa298060ba5b23eba931e686c88f0ef1d7f38e0.tar.gz
Mirrored extra's changes from 8.1-1 to 8.2-2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e46133d8b6fe..fd452dc12f47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Modifications to Use Git Master Source
# ======================================
# Maintainer: James Harvey <jamespharvey20@gmail.com>
-# * This PKGFILE as closely as possible matches extra's binutils 8.1-1
+# * This PKGFILE as closely as possible matches extra's binutils 8.2-2
# * Installs some things to /usr/$CHOST/... {/usr/x86_64-unknown-linux-gnu/...) rather than /usr/...
# * Investigating to determine if this is desired, or if they need to be moved
@@ -16,7 +16,7 @@ pkgbase=gdb-trunk
# of gdb (for arm/avr/...)
pkgname=(gdb-trunk gdb-trunk-common)
_pkgname=binutils-gdb
-pkgver=8.1.r93217.35f48e217a
+pkgver=8.2.r95339.af39b1c216
pkgrel=1
pkgdesc='The GNU Debugger'
arch=(x86_64)
@@ -46,8 +46,7 @@ build() {
--with-system-readline \
--with-python=/usr/bin/python3 \
--with-guile=guile-2.0 \
- --with-system-gdbinit=/etc/gdb/gdbinit \
- --disable-binutils
+ --with-system-gdbinit=/etc/gdb/gdbinit
make
}
@@ -58,6 +57,7 @@ package_gdb-trunk-common() {
cd $_pkgname
make DESTDIR=$pkgdir install
+ make -C bfd DESTDIR=$pkgdir uninstall # conflicts with binutils
rm -r $pkgdir/usr/{bin,include,lib,share/info,share/man}
}
@@ -70,6 +70,7 @@ package_gdb-trunk() {
cd $_pkgname
make DESTDIR=$pkgdir install
+ make -C bfd DESTDIR=$pkgdir uninstall # conflicts with binutils
# install "custom" system gdbinit
install -dm755 $pkgdir/etc/gdb