summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames P. Harvey2018-10-13 02:53:25 -0400
committerJames P. Harvey2018-10-13 02:59:12 -0400
commit6112611f3e75f76ec67c78c58ce75203497b7ac8 (patch)
treee7e6c8589602166441ac0e8bbed73d978c434360 /PKGBUILD
parent5aa298060ba5b23eba931e686c88f0ef1d7f38e0 (diff)
downloadaur-6112611f3e75f76ec67c78c58ce75203497b7ac8.tar.gz
Mirrored extra's changes from 8.2-2(d640ecfc) to 8.2-2(2f19e443).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd452dc12f47..66d7c753c198 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Original Extra Repo
# ===================
# Maintainer: Allan McRae <allan@archlinux.org>
@@ -16,7 +15,7 @@ pkgbase=gdb-trunk
# of gdb (for arm/avr/...)
pkgname=(gdb-trunk gdb-trunk-common)
_pkgname=binutils-gdb
-pkgver=8.2.r95339.af39b1c216
+pkgver=8.2.r95340.f1628857d7
pkgrel=1
pkgdesc='The GNU Debugger'
arch=(x86_64)
@@ -56,10 +55,7 @@ package_gdb-trunk-common() {
conflicts=(gdb-common)
cd $_pkgname
- make DESTDIR=$pkgdir install
- make -C bfd DESTDIR=$pkgdir uninstall # conflicts with binutils
-
- rm -r $pkgdir/usr/{bin,include,lib,share/info,share/man}
+ make -C gdb/data-directory DESTDIR=$pkgdir install
}
package_gdb-trunk() {
@@ -69,8 +65,7 @@ package_gdb-trunk() {
conflicts=(gdb)
cd $_pkgname
- make DESTDIR=$pkgdir install
- make -C bfd DESTDIR=$pkgdir uninstall # conflicts with binutils
+ make -C gdb DESTDIR=$pkgdir install
# install "custom" system gdbinit
install -dm755 $pkgdir/etc/gdb