summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2024-03-12 19:49:38 +0100
committerPopolon2024-03-12 19:49:38 +0100
commit293cd1fb16c0c6413c8ec90204d3196859919533 (patch)
treedb42e1c23025abf4611460fee8b35641b33048b0 /PKGBUILD
parent3d7b6525a476abef84517562818bec642ca6bddb (diff)
downloadaur-gdevelop.tar.gz
try to upgrade the PKGBUILD, it still doesn't work for now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 33 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79c647eb437f..fb7263721a80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,49 @@
-# Maintainer: JKA Network <contacto@jkanetwork.com>
-# Before maintainer: Todor Imreorov for github <blurymind@gmail.com>
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Paulequilibrio
+# Contributor: JKA Network <contacto@jkanetwork.com>
+# Contributor: Todor Imreorov for github <blurymind@gmail.com>
+
pkgname=gdevelop
-pkgver=4.0.97
+_pkgname=GDevelop
+pkgver=5.3.194
pkgrel=1
pkgdesc="A full featured, open source game development software, allowing to create HTML5 and native games without knowing a programming language. All the game logic is made thanks to an intuitive and powerful event based system."
-arch=('x86_64')
+arch=('x86_64' 'riscv64')
url=http://www.compilgames.net
license=('GPL' 'MIT' 'zlib/png')
groups=()
provides=('gdevelop')
-install='gdevelop.install'
makedepends=('rsync' 'cmake' 'git' 'curl')
-depends=('gcc' 'wxgtk' 'openal' 'p7zip' 'glew' 'libsndfile' 'systemd' 'libjpeg-turbo' 'desktop-file-utils' 'gtk-update-icon-cache')
-source=("https://github.com/4ian/GD/archive/$pkgver.tar.gz")
-sha256sums=('cd1041eccd574eab2fa310eab5d54c0368806d8f925d300ff30dc1aa377fa2fc')
+depends=('gcc' 'wxwidgets-gtk3' 'openal' 'p7zip' 'glew' 'libsndfile' 'systemd' 'libjpeg-turbo' 'desktop-file-utils' 'gtk-update-icon-cache' 'emscripten')
+source=("https://github.com/4ian/GDevelop/archive/refs/tags/v${pkgver}.tar.gz"
+ 'gdevelop.desktop')
+sha256sums=('2391dfa0315d2ded50d0752b58082fec0f9cffcd50382330e9a3018d72801c54'
+ '81de9743eb30435302e429263b9bdcf6c3a8b36c52e29b87d9cd2d69be07b9e2')
+
build() {
- cd "$srcdir"/GD-$pkgver
+ cd "${srcdir}"/${_pkgname}-${pkgver}
cd Binaries
- rm -rf build
- mkdir build
+ if [ ! -e build ]; then
+ mkdir build
+ fi
cd build
- cmake ../..
+ cmake ../.. -DCMAKE_INSTALL_PREFIX=/usr
#Build the whole project
- make -j4
+ make
}
+
package() {
- cd "$srcdir"/GD-$pkgver
+ cd "$srcdir"/GDevelop-$pkgver
cd Binaries/build
- make install DESTDIR="$pkgdir"
- #Remove sfml installed libs
- rm -rf "$pkgdir"/usr/local
+ make preinstall DESTDIR="$pkgdir"
+ cmake -P cmake_install.cmake DESTDIR="$pkgdir"
+ install -Dm755 ../Output/Release_Linux/libGDCore.so "${pkgdir}/usr//lib/libGDCore.so"
+ install -Dm755 ../Output/Release_Linux/JsPlatform/libGDJS.so "${pkgdir}/usr/lib/libGDJS.so"
+ cd "$srcdir/${_pkgname}-$pkgver/GDevelop.js"
+ npm install --user root --prefix "${pkgdir}/usr"
+ cd "$srcdir/${_pkgname}-$pkgver/newIDE/app"
+ npm install --user root --prefix "${pkgdir}/usr"
+
+ install -D -m 644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m 644 "${srcdir}/${_pkgname}-${pkgver}/Core/docs/images/glogo.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}