summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoseluCross2016-05-28 17:42:18 +0200
committerJoseluCross2016-05-28 17:42:18 +0200
commitb66c0d03371ec3bd6199d891e1036a267d9b6c2f (patch)
tree0f98807030d488efa49a626aef1e0512c5de14f5 /PKGBUILD
downloadaur-b66c0d03371ec3bd6199d891e1036a267d9b6c2f.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e800c3f7941
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: JKA Network <contacto@jkanetwork.com>
+# Before maintainer: Todor Imreorov for github <blurymind@gmail.com>
+
+pkgname=gdevelop-git
+pkgver=20160528
+pkgrel=1
+pkgdesc="A full featured, open source game development software, allowing to create HTML5 and native games without knowing a programming language. All the game logic is made thanks to an intuitive and powerful event based system."
+arch=('x86_64')
+url="http://www.compilgames.net"
+license=('GPL' 'MIT' 'zlib/png')
+groups=()
+provides=('gdevelop')
+install='gdevelop-git.install'
+makedepends=('rsync' 'cmake' 'git' 'curl')
+depends=('gcc' 'wxgtk' 'openal' 'p7zip' 'glew' 'libsndfile' 'systemd' 'libjpeg-turbo' 'desktop-file-utils' 'gtk-update-icon-cache')
+source=('git+https://github.com/4ian/GD.git')
+md5sums=(SKIP)
+
+build() {
+ cd "$srcdir"/GD
+ cd Binaries
+ rm -rf build
+ mkdir build
+ cd build
+ cmake ../..
+
+ #Build the whole project
+ make -j4
+}
+
+package() {
+ cd "$srcdir"/GD
+ cd Binaries/build
+ make install DESTDIR="$pkgdir"
+ #Remove sfml installed libs
+ rm -rf "$pkgdir"/usr/local
+}