summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Snowhill2024-02-06 12:52:59 -0800
committerChristopher Snowhill2024-02-06 12:52:59 -0800
commit3ea93d3e820bad80397981b90822a407703b566c (patch)
treed15961006149e88999720bebbb71f3955452135e /PKGBUILD
parentbc290a393a7e50ec6de71bb0910afc81c8c58625 (diff)
downloadaur-gdown.tar.gz
v5.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e6436c7de3e..3ea37998094a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
pkgname=gdown
-pkgver=4.7.1
-pkgrel=2
+pkgver=5.1.0
+pkgrel=1
pkgdesc="Download a large file from Google Drive"
arch=('any')
url="https://github.com/wkentaro/gdown"
license=('MIT')
depends=('python' 'python-tqdm' 'python-filelock' 'python-pysocks' 'python-six' 'python-beautifulsoup4' 'python-requests')
-makedepends=('python-setuptools' 'git')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'git' 'python-hatch-vcs' 'python-hatch-fancy-pypi-readme')
source=(git+https://github.com/wkentaro/gdown.git#tag=v${pkgver})
sha512sums=('SKIP')
@@ -22,13 +22,14 @@ prepare() {
build() {
cd "${pkgname}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname}"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
install -Dm755 README.md "${pkgdir}/usr/share/doc/${pkgname}"/README.md
}