summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122020-10-02 18:21:42 +0200
committerwillemw122020-10-02 18:21:42 +0200
commitf48d475ebffe51db1f8e8c84389fed83b4da9186 (patch)
tree8adc2bc31e3a44ea23b36319e12794fd3e9afc99 /PKGBUILD
parent095d3cfa015dac7114d2f8847c057925b1757fb6 (diff)
downloadaur-f48d475ebffe51db1f8e8c84389fed83b4da9186.tar.gz
0.14.13. Switched to Python 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 21 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7ddc12b2a86..ba5c59f702c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
-# Maintainer: Javier Tiá <javier.tia at gmail dot com>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributors: Javier Tiá <javier.tia at gmail dot com>
# Contributors: Javier Vazquez <j.e.vasquez.v at gmail dot com>
# Contributors: Nagy Gábor <ngm.hun at gmail dot com>
pkgname=gdrivefs
-_gitname=GDriveFS
-pkgver=0.14.12
-pkgrel=2
-pkgdesc='A complete FUSE adapter for Google Drive'
-url='https://github.com/dsoprea/GDriveFS'
-depends=(
- 'python2'
- 'python2-dateutil'
- 'python2-fusepy'
- 'python2-gevent'
- 'python2-google-api-python-client'
- 'python2-greenlet'
- 'python2-httplib2'
- 'python2-oauth2client'
- 'python2-six'
- 'python2-wsgiref'
-)
-makedepends=('python2-distribute')
-license=('GPL2')
+pkgver=0.14.13
+pkgrel=1
+pkgdesc="An innovative FUSE wrapper for Google Drive"
arch=('any')
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('607f3cd368070fa67185418c96ab9a1109efc8281e7c8a5dd10bf816cff98554')
+url="https://github.com/dsoprea/GDriveFS"
+license=('GPL2')
+depends=('python-dateutil'
+ 'python-fusepy'
+ 'python-google-api-python-client'
+ 'python-greenlet'
+ 'python-httplib2'
+ 'python-oauth2client'
+ 'python-six')
+makedepends=('python-distribute')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('099a4d64eb7c223e04b0d88c0334331247f69cddb4de425f2b13c620e3778514')
+
+_gitname=GDriveFS
package() {
- cd ${srcdir}/${_gitname}-${pkgver}
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ cd $_gitname-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
}
-# vim:set ts=2 sw=2 et: