summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:39:55 +0200
committerL.G. Sarmiento2015-06-14 19:39:55 +0200
commitc60e415021701a3cc12d7279322c377243600339 (patch)
tree72e67af368b99d79101d66a6f59eeca0f7dc45ea /PKGBUILD
downloadaur-c60e415021701a3cc12d7279322c377243600339.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6604a13758d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: L.G. Sarmiento (Pico) <Luis.Sarmientop-ala-nuclear.lu.se>
+pkgname=geant4-abladata
+_dataname="G4ABLA"
+_foldername="G4ABLA"
+pkgver=3.0
+pkgrel=1
+pkgdesc="Data files for nuclear shell effects in INCL/ABLA hadronic mode"
+url="http://geant4.cern.ch/"
+arch=('any')
+license=('GPL')
+depends=('geant4>=10.0.0')
+#it cannot be optdepend since we require the geant4.sh file to exist
+#to setup the environment variable
+install="${pkgname}.install"
+source=("http://geant4.cern.ch/support/source/${_dataname}.${pkgver}.tar.gz"
+ "${pkgname}.install")
+md5sums=('d7049166ef74a592cb97df0ed4b757bd'
+ '74b0812ebdd78e45551d5d6f7b92c1bb')
+
+## Remove this if you want to keep an even smaller package
+## No need to wait for compression when just installing it.
+PKGEXT='.pkg.tar'
+
+package() {
+ install -d ${pkgdir}/usr/share/${pkgname}
+ mv ${srcdir}/${_foldername}${pkgver} ${pkgdir}/usr/share/${pkgname}
+}