summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilippo Falezza2022-12-18 19:53:21 +0100
committerFilippo Falezza2022-12-18 19:53:21 +0100
commitbd80187910cec8ef9344b099da47f49e1f353360 (patch)
treedb95cb89c4548182e95aad79286900ca4b565c91 /PKGBUILD
parent4b6ae6c7b6a20b1d1e5dd5eb5661d115bd040162 (diff)
downloadaur-bd80187910cec8ef9344b099da47f49e1f353360.tar.gz
moved symlinks inside an install script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e71f13c6146d..6168852432b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='geant4-full'
pkgver=11.1.0
-pkgrel=4
+pkgrel=5
pkgdesc="A simulation toolkit for particle physics interactions - includes all the optional libraries"
depends=(
'cmake>=3.16'
@@ -25,8 +25,15 @@ url="http://geant4.cern.ch/"
arch=('x86_64')
license=('custom: http://geant4.cern.ch/license/')
options=('!emptydirs')
-source=("http://geant4-data.web.cern.ch/releases/geant4-v${pkgver}.tar.gz")
-sha256sums=("051e43066152c373f74746bdffe6f0c9e4175ad9cf1eb7b67da0dc1a05d0b985")
+source=(
+ "http://geant4-data.web.cern.ch/releases/geant4-v${pkgver}.tar.gz"
+ 'geant4-full.install'
+)
+sha256sums=(
+ "051e43066152c373f74746bdffe6f0c9e4175ad9cf1eb7b67da0dc1a05d0b985"
+ '40db557cb8f9d20d91e03dbae2d9bbec75c922b0175ef383f06e44881184c3e4'
+)
+install="geant4-full.install"
build() {
@@ -89,8 +96,6 @@ package() {
cd $srcdir
install -D -m 755 Geant4.sh $pkgdir/etc/profile.d/Geant4.sh
install -D -m 755 Geant4.csh $pkgdir/etc/profile.d/Geant4.csh
- ln -s $pkgdir/usr/include/Geant4/CLHEP $pkgdir/usr/include/CLHEP
- ln -s $pkgdir/usr/include/Geant4/PTL $pkgdir/usr/include/PTL
cd ${srcdir}/build
make DESTDIR="${pkgdir}" install