summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:40:04 +0200
committerL.G. Sarmiento2015-06-14 19:40:04 +0200
commit1806928685198042fa5d4c4a08d15afcdc0e4a5d (patch)
tree1d3128a4b9763edeb450257a45b192854b6c237b /PKGBUILD
downloadaur-1806928685198042fa5d4c4a08d15afcdc0e4a5d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa3e22a28d45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: L.G. Sarmiento (Pico) <Luis.Sarmientop-ala-nuclear.lu.se>
+pkgname=geant4-neutronxsdata
+_dataname="G4NEUTRONXS"
+pkgver=1.4
+pkgrel=1
+pkgdesc="Data files for evaluated neutron cross-sections on natural composition of elements"
+url="http://geant4.cern.ch/"
+arch=('any')
+license=('GPL')
+depends=('geant4>=10.0.0')
+#it cannot be optdepend since we require the geant4.sh file to exist
+#to setup the environment variable
+install="${pkgname}.install"
+source=("http://geant4.cern.ch/support/source/${_dataname}.${pkgver}.tar.gz"
+ "${pkgname}.install")
+md5sums=('665a12771267e3b31a08c622ba1238a7'
+ '1c2baf49b8d69cde060d1538e70717fb')
+
+## Remove this if you want to keep an even smaller package
+## No need to wait for compression when just installing it.
+PKGEXT='.pkg.tar'
+
+package() {
+ install -d ${pkgdir}/usr/share/${pkgname}
+ mv ${srcdir}/${_dataname}${pkgver} ${pkgdir}/usr/share/${pkgname}
+}