summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:39:30 +0200
committerL.G. Sarmiento2015-06-14 19:39:30 +0200
commit62f96fbee9d95c5b9c47c371d29aa0937175d433 (patch)
tree2fe24ef8d96cb0b3d11399e549a835209edcdd23 /PKGBUILD
downloadaur-62f96fbee9d95c5b9c47c371d29aa0937175d433.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbf3f6423d83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: L.G. Sarmiento (Pico) <Luis.Sarmientop-ala-nuclear.lu.se>
+pkgname=geant4-radioactivedata
+_dataname="G4RadioactiveDecay"
+_foldername="RadioactiveDecay"
+pkgver=4.2
+pkgrel=1
+pkgdesc="Data files for radioactive decay hadronic processes"
+url="http://geant4.cern.ch/"
+arch=('any')
+license=('GPL')
+depends=('geant4>=10.01')
+#it cannot be optdepend since we require the geant4.sh file to exist
+#to setup the environment variable
+install="${pkgname}.install"
+source=("http://geant4.cern.ch/support/source/${_dataname}.${pkgver}.tar.gz"
+ "${pkgname}.install")
+md5sums=('2eade8116387ef67d4cd6f14b9cb1512'
+ 'd0144370a60b4de8d8b29c0920f6b00b')
+
+## Remove this if you want to keep an even smaller package
+## No need to wait for compression when just installing it.
+PKGEXT='.pkg.tar'
+
+package() {
+ install -d ${pkgdir}/usr/share/${pkgname}
+ mv ${srcdir}/${_foldername}${pkgver} ${pkgdir}/usr/share/${pkgname}
+}