summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonKarmanov2016-05-18 23:39:54 +0500
committerAntonKarmanov2016-05-18 23:39:54 +0500
commitb5751b81fe22bfee42b2f25d81a4cd91bdcd5abb (patch)
tree945d9685109d4811a78bd9c7b45e611d7b9c9bac /PKGBUILD
downloadaur-b5751b81fe22bfee42b2f25d81a4cd91bdcd5abb.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c864850dccd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Anton Karmanov <starcom24@gmail.com>
+
+pkgname=geany-jedi-complete
+pkgver=8eba66e8
+pkgrel=1
+pkgdesc="A Geany plugin that provides Python code completion using jedi."
+arch=("any")
+url="https://github.com/notetau/geany-jedi-complete"
+license=('GPL2')
+depends=('geany' 'python-jedi' 'curl')
+makedepends=()
+checkdepends=()
+optdepends=('python2-jedi')
+source=("https://github.com/notetau/geany-jedi-complete/archive/$pkgver.tar.gz")
+md5sums=('861ac1dc0d1fc3499c9bbd8641a717a5')
+validpgpkeys=()
+
+build() {
+ cd $srcdir/$(tar -tf $pkgver.tar.gz | head -n 1)
+ make
+}
+
+package() {
+ mkdir -p $pkgdir$(pkg-config --variable=libdir geany)/geany
+ cd $srcdir/$(tar -tf $pkgver.tar.gz | head -n 1)
+ make PREFIX="$pkgdir$(pkg-config --variable=libdir geany)/geany" install
+}