summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:21:39 +0200
committerAlexander F Rødseth2015-06-10 15:21:39 +0200
commit9f8b93ef4626250ced5b7bd5f84c1819b1cae979 (patch)
treebc0cbebbc8a74fa0a3192acdbf8d9f0717eb89a9 /PKGBUILD
downloadaur-9f8b93ef4626250ced5b7bd5f84c1819b1cae979.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6487eb6b520f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: eht16 <enrico.troeger@uvena.de>
+# Contributor: Addict7 <nicolasfloquet@gmail.com>
+
+pkgname=geany-plugins-git
+pkgver=1.24.213.gc12f0d3
+pkgrel=1
+pkgdesc='Various plugins for Geany'
+arch=('x86_64' 'i686')
+url='http://plugins.geany.org/'
+license=('GPL')
+depends=('geany-git' 'vte' 'lua' 'libwebkit' 'ctpl' 'gpgme' 'gtkspell' 'hicolor-icon-theme')
+makedepends=('git' 'libtool' 'python' 'gpgme' 'ctpl' 'lua' 'intltool' 'vala')
+optdepends=('hspell: hebrew spell checker')
+install="$pkgname.install"
+provides=('geany-plugins')
+conflicts=('geany-plugins-svn' 'geany-plugins')
+source=('geany-plugins::git://github.com/geany/geany-plugins.git')
+md5sums=('SKIP')
+
+# These plugins does not build. Skipping until upstream makes them compile.
+_skip='geanygendoc,geanyprj,projectorganizer'
+
+pkgver() {
+ cd geany-plugins
+ git describe --tags | sed 's/-/./g'
+}
+
+prepare() {
+ # Fix a problem with the waf script
+ sed 's/revision > 0/revision != ""/g' -i geany-plugins/wscript
+}
+
+build() {
+ cd geany-plugins
+ ./waf configure --skip-plugins=$_skip
+ ./waf build
+}
+
+package() {
+ cd geany-plugins
+ ./waf install --destdir="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: