summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2015-09-22 20:32:31 +0200
committeranthraxx2015-09-22 20:32:31 +0200
commit3238a6443f9718f36fc95ba59b629caa32640aa9 (patch)
tree8d43b447afcd5a08c51096be7bc8b5db7e9dc703 /PKGBUILD
downloadaur-3238a6443f9718f36fc95ba59b629caa32640aa9.tar.gz
addpkg: gef-git 0.0.0.86.34f2ad7-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..233eec738188
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgname=gef-git
+_gitname=gef
+pkgver=0.0.0.86.34f2ad7
+pkgrel=1
+pkgdesc="Multi-Architecture GDB Enhanced Features for Exploiters & Reverse-Engineers"
+url='https://github.com/hugsy/gef'
+arch=('any')
+license=('MIT')
+depends=( 'gdb' 'python')
+optdepends=(
+ 'python-capstone: extended disassemble support'
+ 'ropgadget: ROP support'
+ 'rarade2-bindings: code assemble support'
+)
+makedepends=('git')
+provides=('gef')
+conflicts=('gef')
+install='gef.install'
+source=(${pkgname}::git+https://github.com/hugsy/${_gitname})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "0.0.0" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname}
+ python -m compileall .
+ python -O -m compileall .
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm 644 *.py -t "${pkgdir}/usr/share/${_gitname}"
+ install -Dm 644 __pycache__/* -t "${pkgdir}/usr/share/${_gitname}/__pycache__"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 docs/* -t "${pkgdir}/usr/share/doc/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et: