summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Schlatow2015-06-20 17:44:41 +0200
committerJohannes Schlatow2015-06-20 17:44:41 +0200
commit57811ef07dc968f7cdf98b254cfc2530eb673c5d (patch)
treec73d3b9ebd8a3d20aa92f112b1efdf5272e27e3c /PKGBUILD
downloadaur-57811ef07dc968f7cdf98b254cfc2530eb673c5d.tar.gz
migrate to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ace0b55460c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Johannes Schlatow <johannes.schlatow@googlemail.com>
+
+pkgname=genode-toolchain-bin
+pkgver=14.11
+pkgrel=1
+pkgdesc="GCC-based toolchain for the genode framework"
+arch=('i686' 'x86_64')
+url="http://genode.org"
+license=('GPL2')
+makedepends=('tar')
+provides=('genode-toolchain')
+options=('!strip' 'staticlibs')
+
+_arch="x86_64"
+[ "$CARCH" == 'i686' ] && _arch="x86_32"
+
+_filename="genode-toolchain-${pkgver}-${_arch}.tar.bz2"
+source=("http://dfn.dl.sourceforge.net/project/genode/genode-toolchain/${pkgver}/${_filename}")
+md5sums=('4e78b5d1f8205789af934bb7c7643908')
+noextract=(${_filename})
+
+package() {
+ cd ${pkgdir}
+ tar xf "${srcdir}/${_filename}"
+ tar tvf "${srcdir}/${_filename}" | grep "link to" | awk '{print "ln -sf /" $9 " ." $6 | "/bin/bash"}'
+}