summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXianwen Chen2017-02-17 15:28:17 +0000
committerXianwen Chen2017-02-17 15:28:17 +0000
commit1a01e04172d736f659adaab20c8e31178d6ead67 (patch)
treef8b30285f14f43ee899125de71700837ea8ed06d /PKGBUILD
downloadaur-1a01e04172d736f659adaab20c8e31178d6ead67.tar.gz
Revised
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e17fb267a50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Xianwen Chen <xianwen.chen@gmail.com>
+
+pkgname=geoda
+pkgver=1.8.12
+pkgrel=1
+pkgdesc='GeoDa is an Exploratory (Spatial) Data Analysis and Spatial Regression software, for spatial data analysis including spatial econometrics.'
+arch=('x86_64')
+license=('custom:free_for_non_commercial_use')
+url="http://geodacenter.github.io/download_linux.html"
+depends=('bash')
+makedepends=('wget' 'dpkg')
+install=$pkgname.install
+source=(
+ "https://s3.amazonaws.com/geoda/software/GeoDa-1.8.12-Ubuntu-64bit.deb"
+)
+
+package()
+{
+ cd "$srcdir/"
+ dpkg -X ../GeoDa-1.8.12-Ubuntu-64bit.deb ./
+ install -d $pkgdir/usr/bin/
+ install -d $pkgdir/usr/local/geoda/
+ install -d $pkgdir/usr/share/applications/
+ install -d $pkgdir/usr/share/icons/
+}
+
+sha512sums=('9bb5f266dc8005093e55f271cb3c0803df7b57e1b1889a1ad5d6c763c319f12f5a8736d88672d1cd17e1fcd6ec3b3e6f45b6f6eec421a02355c7df43b7a42e95')