summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-17 05:57:00 +0300
committerDimitris Kiziridis2020-07-17 05:57:00 +0300
commitb2c3c60361e860f2c2271b73d11bf0fa4da26778 (patch)
tree8f363d0731eecc239b2e13afb194e9c8cad3a574 /PKGBUILD
downloadaur-b2c3c60361e860f2c2271b73d11bf0fa4da26778.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8379c05c7e37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=geometrize-bin
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A desktop app that geometrizes images into geometric primitives"
+arch=('x86_64')
+url='https://www.geometrize.co.uk'
+license=('GPL')
+provides=('geometrize')
+depends=('zlib')
+makedepends=('gendesk')
+options=('!strip')
+noextract=("${pkgname%-bin}-${pkgver}.AppImage")
+source=("${pkgname%-bin}-${pkgver}.AppImage::https://github.com/Tw1ddle/geometrize/releases/download/v${pkgver}/geometrize_${pkgver}_linux.AppImage")
+sha256sums=('b2d586029fb9371e1c96869e15b65fceb5ef96fd99f58242e914552ad288a242')
+
+package() {
+ chmod 755 ./${pkgname%-bin}-${pkgver}.AppImage
+ ./${pkgname%-bin}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/Geometrize.png "${pkgdir}/usr/share/pixmaps/geometrize.png"
+ gendesk -f -n --pkgname "${pkgname%-bin}" \
+ --pkgdesc "$pkgdesc" \
+ --name "Geometrize" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname%-bin}" \
+ --categories 'Graphics;Application' \
+ --icon "${pkgname%-bin}"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.AppImage"
+ ln -s /opt/geometrize/${pkgname%-bin}.AppImage "${pkgdir}/usr/bin/geometrize"
+} \ No newline at end of file