summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2020-05-05 18:48:38 +0200
committerChristopher Arndt2020-05-05 18:48:38 +0200
commit7a7db4bed8ae1e8ead03738bf135769c72cf0db4 (patch)
treea0088d315f7815bfb5a57994de53c6ab63f9e681 /PKGBUILD
parent47b95ad470b4ad2bdcf072d468261c1dbb2735a7 (diff)
downloadaur-7a7db4bed8ae1e8ead03738bf135769c72cf0db4.tar.gz
Adapt to upstream changes
* Update project and git repo URL * Remove obsolete CMakeList.txt patching * Fix preset installation * Add 'lv2-plugins' group
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a861a3f52434..4b8fa385b723 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
_pkgname=geonkick
pkgname="${_pkgname}-git"
-pkgver=1.9.0.r586.455574b
+pkgver=2.1.0.r815.f9b8340
pkgrel=1
pkgdesc="A free software percussion synthesizer (git version)"
arch=('i386' 'x86_64')
-url="https://gitlab.com/geontime/geonkick"
+url="https://gitlab.com/iurie-sw/geonkick"
license=('GPL3')
-groups=('pro-audio')
+groups=('pro-audio' 'lv2-plugins')
depends=('cairo' 'desktop-file-utils' 'hicolor-icon-theme' 'libsndfile' 'shared-mime-info')
makedepends=('cmake' 'jack' 'lv2' 'rapidjson' 'redkite' 'sord')
optdepends=('jack: for stand-alone application')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://gitlab.com/geontime/geonkick.git")
+source=("${_pkgname}::git+https://gitlab.com/iurie-sw/geonkick.git")
sha512sums=('SKIP')
@@ -25,9 +25,11 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/${_pkgname}"
- # don't call post-install commands
- sed -i -e '/^install.CODE/d' data/CMakeLists.txt
+ cd "${srcdir}/${_pkgname}/doc/examples"
+ # extract drumkits
+ for tarxz in *.tar.xz; do
+ tar -xvJf "$tarxz"
+ done
}
build() {
@@ -48,9 +50,18 @@ package() {
cd build
make DESTDIR="$pkgdir/" install
)
+ # desktop file
install -vDm 644 "data/${_pkgname}.desktop" \
-t "${pkgdir}/usr/share/applications"
- install -dm 755 "${pkgdir}/usr/share/doc/${pkgname}/examples"
- cp -r --preserve=mode examples/* "${pkgdir}/usr/share/doc/${pkgname}/examples"
- install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ # example preset & kits
+ install -vDm 644 doc/examples/*.{gkick,gkit} \
+ -t "${pkgdir}/usr/share/${_pkgname}/presets"
+ for directory in doc/examples/*; do
+ if [[ -d "$directory" ]]; then
+ install -vDm 644 "$directory/"*.{gkick,gkit} \
+ -t "${pkgdir}/usr/share/${_pkgname}/presets/$(basename "$directory")"
+ fi
+ done
+ # documentation
+ install -vDm 644 README.md NEWS.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}