summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2018-08-28 11:20:33 +0300
committerChristoph Fink2018-08-28 11:20:33 +0300
commitcf7a8909d2d38f3160f130faaf8759a56884e514 (patch)
treef1d9131e62de20a57778040443a846ce6d1ce226 /PKGBUILD
downloadaur-cf7a8909d2d38f3160f130faaf8759a56884e514.tar.gz
geos-git 3.7.0rc1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0df7bc55190
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+pkgname=geos-git
+pkgver=3.7.0rc1.r9.g1be02b36
+pkgrel=1
+
+pkgdesc="C++ port of the Java Topology Suite (git version)"
+url="http://trac.osgeo.org/geos/"
+license=('LGPL')
+
+arch=('i686' 'x86_64')
+depends=('gcc-libs' 'bash')
+conflicts=('geos')
+provides=('geos')
+
+source=("${pkgname}::git+https://git.osgeo.org/gitea/geos/geos.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}