summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDct Mei2020-03-15 19:34:22 +0800
committerDct Mei2020-03-15 19:34:22 +0800
commit374253722b25df5594b358db2339d152d7153e28 (patch)
tree52b3f6a0b098e135ad2efb5e6a4aaec03dcde08c /PKGBUILD
parent340cd4ec3112c2d687a4d3461ecc3a606390e910 (diff)
downloadaur-374253722b25df5594b358db2339d152d7153e28.tar.gz
version number correction
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c37c585c4322..e822f5330da8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,11 @@ source=("git+https://github.com/geph-official/gephgui.git"
sha512sums=('SKIP'
'94e30f293a7c7ac232bdcfb9549bab8d4aeacd91a48e249b37a996b3876776760650ff3fe7684029d544dd6806f32e72476bfca2cb9ec91d2bea7cd24bc162d0')
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd "$_pkgname"
npm install --devDependencies