summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSiavash Askari Nasr2021-07-03 23:43:15 +0430
committerSiavash Askari Nasr2021-07-03 23:43:15 +0430
commit11b70c2175e1a1e0a829627e61af0352089895ae (patch)
treeb6bcfecdd486038d635f87021c73ee2d56f35c76 /PKGBUILD
downloadaur-11b70c2175e1a1e0a829627e61af0352089895ae.tar.gz
Publish germanium-bin v1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45f20f579ba2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Siavash Askari Nasr <ciavash@protonmail.com>
+pkgname=germanium-bin
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Generate image from source code"
+arch=('x86_64' 'i686' 'aarch64')
+url='https://github.com/matsuyoshi30/germanium'
+license=(MIT)
+provides=("${pkgname%-bin}")
+source_x86_64=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_x86_64.tar.gz")
+source_i686=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_386.tar.gz")
+source_aarch64=("$pkgname-$pkgver.tar.gz::$url/releases/download/v$pkgver/${pkgname%-bin}_${pkgver}_linux_arm64.tar.gz")
+sha256sums_x86_64=('08c9fd242960997b82a3d5d13685e4794aed4cf723216f3e31296e0cc1fc43c7')
+sha256sums_i686=('a2bdb2041cb81c0db21754f4098549fac147b664911ceab3a85d10ad22859736')
+sha256sums_aarch64=('98f86954539239283392ca64417156b5c753507d69161a6452f8a3e8f0cbeee1')
+
+package() {
+ install -Dm755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 CREDITS -t "${pkgdir}/usr/share/doc/${pkgname%-bin}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-bin}"
+}