summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbobi2019-10-15 11:10:40 +0200
committerbobi2019-10-15 11:10:40 +0200
commit437f7d6d48953edc0aa4e2f62a8cc496dba6942c (patch)
tree17f632f6b14d86e017f3b4322904c73a589bbdef /PKGBUILD
parent63ffe443f7c70298cd3339ba9d3bbc3bb14b4ed1 (diff)
downloadaur-germinal.tar.gz
Adding a patch so that a new window is open when middle-clicking the application icon in Gnome Shell.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1022108bcaee..f8c1650b0f1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,14 @@
pkgname=germinal
pkgver=26
-pkgrel=1
+pkgrel=2
pkgdesc="Minimalist terminal emulator based on vte and tmux"
+gdeskpatch="gnome-desktop.patch"
license=('GPL3')
url="https://github.com/Keruspe/Germinal"
-source=("http://www.imagination-land.org/files/$pkgname/$pkgname-$pkgver.tar.xz")
+source=("http://www.imagination-land.org/files/$pkgname/$pkgname-$pkgver.tar.xz"
+ "$gdeskpatch")
makedepends=('intltool' 'appstream-glib')
@@ -16,10 +18,13 @@ depends=('glib2' 'vte3' 'pango' 'tmux' 'pcre2')
install=$pkgname.install
arch=('i686' 'x86_64')
-md5sums=('8d22320954de55a098b772b2037a1455')
+md5sums=('8d22320954de55a098b772b2037a1455'
+ 'f5b9996bcb2856ce3e2f91d739f81612')
build () {
+ cp $gdeskpatch "$srcdir/$pkgname-$pkgver"
cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 < $gdeskpatch
./configure --sysconfdir=/etc \
--libexecdir=/usr/lib