summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBiehl Daniel2017-11-21 17:00:43 +0100
committerBiehl Daniel2017-11-21 17:00:43 +0100
commitcade1b75e495b89843d3c61804012365d084df60 (patch)
treefbcd4f036a1295a54daf156ecde3700c84354001 /PKGBUILD
downloadaur-cade1b75e495b89843d3c61804012365d084df60.tar.gz
first version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f7050c9694d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel Biehl dbiehl@live.de
+
+pkgname=getgauge
+pkgver=0.9.4
+pkgrel=1
+pkgdesc="Light weight cross-platform test automation tool for authoring test cases in the business language."
+arch=('x86_64' 'i686')
+url="https://getgauge.io"
+license=('GPL3')
+makedepends=('go' "godep")
+
+source=("https://github.com/getgauge/gauge/archive/v$pkgver.tar.gz")
+sha256sums=('b517997c5675b6997cb0707ab81b86053a10937b186458a96b65c3ec64caffc6')
+_gourl="/github.com/getgauge/gauge"
+
+prepare() {
+ export GOPATH="${srcdir}"
+
+ cd "$srcdir"
+ mkdir -p "src/github.com/getgauge/"
+ mv "gauge-$pkgver" "src/github.com/getgauge/gauge"
+}
+
+build() {
+ cd "${srcdir}/src/github.com/getgauge/gauge"
+
+ godep restore
+ go run build/make.go
+}
+
+package() {
+ cd "${srcdir}/src/github.com/getgauge/gauge"
+
+ go run build/make.go --install --prefix="$pkgdir/usr"
+}
+