summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Biehl2018-11-13 09:36:30 +0100
committerDaniel Biehl2018-11-13 09:36:30 +0100
commitea771ce58581cfc99bb89a773da68447bab2bbb4 (patch)
treeac4d4dee645764e82ffef3524a1039e1998754ef /PKGBUILD
parent1c6be6fa3968b7fcc1c8c60c5d1fef34c9036c91 (diff)
downloadaur-ea771ce58581cfc99bb89a773da68447bab2bbb4.tar.gz
correct build function in PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 672a604238bb..afe3f82fcfdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,29 @@
pkgname=getgauge
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Light weight cross-platform test automation tool for authoring test cases in the business language."
arch=('x86_64' 'i686')
url="https://getgauge.io"
license=('GPL3')
-makedepends=('go' "godep")
+makedepends=('go')
source=("https://github.com/getgauge/gauge/archive/v$pkgver.tar.gz")
sha256sums=('c0092f40940469853ef0810b6ae388b405b60c7a40dc5585af841652da40cee8')
_gourl="/github.com/getgauge/gauge"
-prepare() {
- export GOPATH="${srcdir}"
-
+prepare() {
cd "$srcdir"
mkdir -p "src/github.com/getgauge/"
mv "gauge-$pkgver" "src/github.com/getgauge/gauge"
}
-build() {
+build() {
+ export GOPATH="${srcdir}"
+
cd "${srcdir}/src/github.com/getgauge/gauge"
-
- #godep restore
+
go run build/make.go
}